cool reader won't load

Post Reply
cooolreader
Posts: 3
Joined: Sun Feb 28, 2016 8:41 pm
My ELO: 0-1000

cool reader won't load

Post by cooolreader » Sun Feb 28, 2016 8:57 pm

First thanks for making this wonderful ereader software...

Sometimes the reader won't load, check the video, happens when you change the fonts or update one of the settings. Happy twice already....

Suggested fix, might a 'reset' button? or add options to open files in the within the "file manager"

kobo aura, running on 2015.12 release. Please check the video

https://www.youtube.com/watch?v=ffGy6hE ... e=youtu.be

sergeyvl
Posts: 1564
Joined: Sun Nov 13, 2011 5:43 pm
My ELO: 1700-1800
Location: Харьков
Contact:

Re: cool reader won't load

Post by sergeyvl » Mon Feb 29, 2016 12:50 pm

Thanks for reporting! I'll try to investigate and fix it in the nearest version. Please subscribe this topic and keep in touch. Some further details from you may be necessary.

LittleBiG
Posts: 56
Joined: Tue Feb 10, 2015 11:56 am
My ELO: I don't know

Re: cool reader won't load

Post by LittleBiG » Wed Mar 02, 2016 1:40 pm

It happened to me too, many times, always after changing the "enable document internal style" option.
Kobo Mini v3.4.1 and Pocketbook Touch Lux 2 v5.8

sergeyvl
Posts: 1564
Joined: Sun Nov 13, 2011 5:43 pm
My ELO: 1700-1800
Location: Харьков
Contact:

Re: cool reader won't load

Post by sergeyvl » Wed Mar 02, 2016 1:52 pm

Seems that it is a bug of CR engine. I'll use the latest version of CR engine in 2016.03. Probably this problm will gone.

colibris79
Posts: 13
Joined: Sun Nov 29, 2015 12:57 pm
My ELO: I don't know

Re: cool reader won't load

Post by colibris79 » Sun Mar 06, 2016 1:28 am

This is a known problem from Coolreader. Apparently happens with some "buggy" epubs. You have to disable the internal styles of that book or try to fix in the epub code whatever is causing the style problem.

cooolreader
Posts: 3
Joined: Sun Feb 28, 2016 8:41 pm
My ELO: 0-1000

Re: cool reader won't load

Post by cooolreader » Wed Mar 16, 2016 4:59 am

sergeyvl wrote:Seems that it is a bug of CR engine. I'll use the latest version of CR engine in 2016.03. Probably this problm will gone.
Is 2016.03 even out yet? Can't see it in the forum

sergeyvl
Posts: 1564
Joined: Sun Nov 13, 2011 5:43 pm
My ELO: 1700-1800
Location: Харьков
Contact:

Re: cool reader won't load

Post by sergeyvl » Fri Mar 18, 2016 8:54 pm

cooolreader wrote:
sergeyvl wrote:Seems that it is a bug of CR engine. I'll use the latest version of CR engine in 2016.03. Probably this problm will gone.
Is 2016.03 even out yet? Can't see it in the forum
2016.03 is released.

Torte
Posts: 2
Joined: Fri May 20, 2016 2:00 pm
My ELO: I don't know

Re: cool reader won't load

Post by Torte » Fri May 20, 2016 2:22 pm

I have this behaviour with version 2016.03 (CR3 crashing after start or hanging with a white screen - after enabling doc internal style). With the former version (2015.?? - is there a way to find out the exact version?), I did not notice this - but as the crash is not reliably reproducable, this could have been just luck.

This is the content of "cr3.log.txt" after a crash:

Code: Select all

[2016-05-20 15:06:45]   I       Program started, version: 2016.02.1fc765836cec
[2016-05-20 15:06:46]   I       Pipe thread started: /tmp/vlasovsoft/fifo2
[2016-05-20 15:06:46]   I       CR3View::loadHistory( /mnt/onboard/.adds/vlasovsoft/cr3/data/cr3hist.bmk )
[2016-05-20 15:06:46]   I       writeFifoCommand: /tmp/vlasovsoft/fifo1 <== n+
After clearing the contents of the "cr3/data/cache" folder, CR3 starts correctly.
So for those asking for a "reset button", this may help: Add a script with following content to the kobostartmenu:

Code: Select all

#!/bin/sh
rm /mnt/onboard/.adds/vlasovsoft/cr3/data/cache/*
and put it e.g. as "cr3_cache_clean.sh" into "/mnt/onboard/.adds/kbmenu_user/scripts/tests/"
Make sure, you use Unix lineendings (LF) for this file instead of Windows (CRLF).

colibris79
Posts: 13
Joined: Sun Nov 29, 2015 12:57 pm
My ELO: I don't know

Re: cool reader won't load

Post by colibris79 » Sat Jun 04, 2016 3:07 am

So just copying the cr3_cache_clean.sh script into "/mnt/onboard/.adds/kbmenu_user/scripts/tests/"? Do we have to run the script everytime we face this problem or will it run automatically?

Torte
Posts: 2
Joined: Fri May 20, 2016 2:00 pm
My ELO: I don't know

Re: cool reader won't load

Post by Torte » Wed Jun 29, 2016 7:12 am

The script has to be started manually, when the startup problem happens. You could automate it by putting the "rm" line into the coolreader startup script (.adds/vlasovsoft/cr3.sh), to run it each time you open coolreader - but I don't think this is necessary, cause the crash happens not that often, and rebuilding the cache each time will be a waste of battery charge.

Post Reply