OPDS connection not showing anything on KA1

Post Reply
MicaOlaAdams
Posts: 9
Joined: Sun Oct 16, 2016 9:42 am
My ELO: I don't know

OPDS connection not showing anything on KA1

Post by MicaOlaAdams » Sun Oct 16, 2016 9:47 am

Hi there,

I set up an OPDS connection to my calibre server. For an instant I can see a loading message (Loading...), but no entries are shown just a blank page.

Any ideas what might be causing this?

And many thanks for coding CoolReader. It's a great piece of software

Mica

sergeyvl
Posts: 1543
Joined: Sun Nov 13, 2011 5:43 pm
My ELO: 1700-1800
Location: Харьков
Contact:

Re: OPDS connection not showing anything on KA1

Post by sergeyvl » Sun Oct 16, 2016 10:02 am

MicaOlaAdams wrote:Hi there,

I set up an OPDS connection to my calibre server. For an instant I can see a loading message (Loading...), but no entries are shown just a blank page.

Any ideas what might be causing this?

And many thanks for coding CoolReader. It's a great piece of software

Mica
Thanks for reporting. I'll install calibre and check this problem tomorrow

sergeyvl
Posts: 1543
Joined: Sun Nov 13, 2011 5:43 pm
My ELO: 1700-1800
Location: Харьков
Contact:

Re: OPDS connection not showing anything on KA1

Post by sergeyvl » Mon Oct 17, 2016 11:16 am

Hi!

1. What format of books in your library?
2. Are you using calibre-server.exe?
3. Also what url to opds server did you add into application?

MicaOlaAdams
Posts: 9
Joined: Sun Oct 16, 2016 9:42 am
My ELO: I don't know

Re: OPDS connection not showing anything on KA1

Post by MicaOlaAdams » Mon Oct 17, 2016 3:30 pm

Hi Sergey,

I have mostly epub files in my library, ocassionaly a pdf or chm file.
I start my calibre server through the menu bar icon "Connect/Share -> Start Content Server"
My catalog setting for the server is: calibre|http://192.168.1.89:8080

CoolReader does load the calibre xml file as opds.xml (see attachement), but it does only show a blank page on the reader.
I'm running CoolReader on an KA1. Maybe there is an issue with the screen size.

One more question: Is it possible to set the "Find text" function as a tap zone gesture?

Once again: Many thanks for your work.

Mica
Attachments
opds.xml.zip
xml file as downloaded from my calibre content server
(2.26 KiB) Downloaded 74 times

sergeyvl
Posts: 1543
Joined: Sun Nov 13, 2011 5:43 pm
My ELO: 1700-1800
Location: Харьков
Contact:

Re: OPDS connection not showing anything on KA1

Post by sergeyvl » Mon Oct 17, 2016 4:04 pm

MicaOlaAdams wrote:Hi Sergey,

My catalog setting for the server is: calibre|http://192.168.1.89:8080

Mica
No! :)

It just the web server. The OPDS server url is:

calibre|http://192.168.1.89:8080/opds

This URL works fine on my Win7 virtualbox

MicaOlaAdams
Posts: 9
Joined: Sun Oct 16, 2016 9:42 am
My ELO: I don't know

Re: OPDS connection not showing anything on KA1

Post by MicaOlaAdams » Mon Oct 17, 2016 4:13 pm

oh boy! That was it. No I feel a little silly ;)

Post Reply